شرح

افضل موقع شرح عربى متكامل
 
الرئيسيةالبوابةاليوميةس .و .جبحـثالأعضاءالمجموعاتالتسجيلدخول الروبوت جالب المواضيع





شاطر | 
 

 عملية بسيطة في السيرفر هتغير معني التصفح في الشبكات فعالة 100 %

استعرض الموضوع السابق استعرض الموضوع التالي اذهب الى الأسفل 
كاتب الموضوعرسالة
Admin
Admin


عدد المساهمات : 692
نقاط : 2567
تاريخ التسجيل : 24/10/2011

مُساهمةموضوع: عملية بسيطة في السيرفر هتغير معني التصفح في الشبكات فعالة 100 %   الخميس نوفمبر 13, 2014 3:56 pm

[size=32]السلام عليكم ورحمة الله وبركاته
[/size][size=32]ها اطرح عليكم النهاردة إن شاء الله طريقة بسيطة هتغير معني التصفح في الشبكات
[/size][size=32]الفكرة كانت مطروحة قبل كدة بس مش بالطريقة دي تعالو مع بعض نشوف ايه هيا 
[/size][size=32]بس قبل ما تطبق معانا الفكرة لازم يكون النت عندك يستحمل علي الأقل يكون 4 ميجا 
[/size][size=32]الفكرة ؟
[/size][size=32]هنعطى لليوزر سرعة قليلة إفتراضا 256k ودي هتكون سرعة اي تحميل 
[/size][size=32]وهنستثني منهم
[/size][size=32]التصفح و الفيديوهات 
[/size][size=32]والألعاب الأون لاين زي ( المزرعة السعيدة )
[/size][size=32]هنفتح للتصفح سرعة النت كاملة
[/size][size=32]وهنعطى للفديوهات والألعاب سرعة ( 1 ميجا او اكتر زي ماتحب )
[/size][size=32]الشرح تم علي النسخة (5.25) 
[/size][size=32]لايعمل علي النسخ 6 لأن الشركة غيرت طريقة التوزيع بالنسخة وعموما النسخة 6 زبالة حتي الآن ياريت محدش يتعامل بيها في اي حاجة لحد اما تنتهي لأن هتقابلك مشاكل كتير معاها
[/size][size=32]المهم 
[/size][size=32]الصور اللي جاية دي هتوضح الفكرة أكتر
[/size][size=32]1- اليوزر اللي انا فاتح بيه حاليا علي جهازي في المحل وسرعته ( 256k ) للتجربة
[/size][size=32]ومن الأفضل أنك تعطي للمشتركين سرعة قليلة ولتكن 400k لأن الأغلبية العظمي من المشتركين بتستخدم التصفح واليوتيوب والألعاب أون لاين في أغلب الأحيان 
[/size][size=32]وده هيوفر كتير جدا في الباندويث بتاع شبكتك[/size]
[size=32]
[/size]
[size=32]2- تجربة التحميل باليوزر ده
[/size][size=32]اي امتداد هنحمله غير اللي قولنا عليهم هيحمل بسرعة البروفايل عادي جدا[/size]
[size=32]
[/size]
[size=32]6- إزاي ترفع السرعة للفيديوهات والألعاب أكتر من 1 ميجا[/size]
[size=32]
[/size]


[size=32]8- نيجي بقا للكود المستخدم في العملية دي واللي هيلخص الحكاية دي كلها
[/size][size=32]قبل ما تضيف الكود امسح اي أكواد قديمة عندك تتعارض مع الكود ده[/size]


[size=32]سكربت تصفح المواقع فقط[/size]


/ip firewall layer7-protocol
add name=jpg regexp=.jpg
add name=gif regexp=.gif
add name=png regexp=.png

/ip firewall mangle
add action=mark-connection chain=prerouting comment="\C7\E1\CA\D5\DD\CD" disabled=no layer7-protocol=jpg new-connection-mark=Browsing passthrough=yes
add action=mark-connection chain=prerouting disabled=no layer7-protocol=gif new-connection-mark=Browsing passthrough=yes
add action=mark-connection chain=prerouting disabled=no layer7-protocol=png new-connection-mark=Browsing passthrough=yes
add action=mark-packet chain=postrouting connection-mark=Browsing disabled=no new-packet-mark=Browsing passthrough=no

/queue type
add kind=pcq name="Full Speed" pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 \
pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Browsing packet-mark=Browsing parent=global-out priority=1 queue="Full Speed"



الاسكربت كامل


/ip firewall layer7-protocol
add name=jpg regexp=.jpg
add name=gif regexp=.gif
add name=png regexp=.png
add name=swf regexp=.swf
add name=videoplayback regexp=videoplayback

/ip firewall mangle
add action=mark-connection chain=prerouting comment="\C7\E1\CA\D5\DD\CD" disabled=no layer7-protocol=jpg new-connection-mark=Browsing passthrough=yes
add action=mark-connection chain=prerouting disabled=no layer7-protocol=gif new-connection-mark=Browsing passthrough=yes
add action=mark-connection chain=prerouting disabled=no layer7-protocol=png new-connection-mark=Browsing passthrough=yes
add action=mark-packet chain=postrouting connection-mark=Browsing disabled=no new-packet-mark=Browsing passthrough=no
add action=mark-connection chain=prerouting comment="\C7\E1\C3\E1\DA\C7\C8" disabled=no layer7-protocol=swf new-connection-mark=swf passthrough=yes
add action=mark-packet chain=postrouting connection-mark=swf disabled=no new-packet-mark=swf passthrough=no
add action=mark-connection chain=prerouting comment="\C7\E1\DD\ED\CF\ED\E6" disabled=no layer7-protocol=videoplayback new-connection-mark=videoplayback passthrough=yes
add action=mark-packet chain=postrouting connection-mark=videoplayback disabled=no new-packet-mark=videoplayback passthrough=no

/queue type
add kind=pcq name=300k pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 \
pcq-rate=300k pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000
add kind=pcq name=512k pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 \
pcq-rate=512k pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000
add kind=pcq name=700k pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 \
pcq-rate=700k pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000
add kind=pcq name=1M pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 \
pcq-rate=800k pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000
add kind=pcq name=2M pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 \
pcq-rate=2M pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000
add kind=pcq name=3M pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 \
pcq-rate=3M pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000
add kind=pcq name=4M pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 \
pcq-rate=4M pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000
add kind=pcq name="Full Speed" pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 \
pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Browsing packet-mark=Browsing parent=global-out priority=1 queue="Full Speed"
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=videoplayback packet-mark=videoplayback parent=global-out priority=8 queue=1M
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=swf packet-mark=swf parent=global-out priority=8 queue=1M

الرجوع الى أعلى الصفحة اذهب الى الأسفل
معاينة صفحة البيانات الشخصي للعضو http://shar7.arabepro.com
 
عملية بسيطة في السيرفر هتغير معني التصفح في الشبكات فعالة 100 %
استعرض الموضوع السابق استعرض الموضوع التالي الرجوع الى أعلى الصفحة 
صفحة 1 من اصل 1

صلاحيات هذا المنتدى:لاتستطيع الرد على المواضيع في هذا المنتدى
شرح :: شروحات الشبكات بأنواعها :: شرح المايكروتك وملحقاته-
انتقل الى: